1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Under Investigation Game constantly closing since this weeks patch

Discussion in 'Technical Support' started by TarkusBlack, Apr 15, 2018.

  1. TarkusBlack

    TarkusBlack Witch 62 EU

    Joined:
    Mar 30, 2016
    Messages:
    884
    Likes Received:
    1,282
    5 minutes after I minimize the game, fishing at event lake:

    Code:
    18-04-24 20:00:15 0x2E58-00-1 eErrNoServiceLog(Service log!): setEndGame : 8
    18-04-24 20:00:15 0x2E58-00-1 eErrNoServiceLog(Service log!): setEndGame()
    18-04-24 20:00:15 0x1A48-00-1 --(--): [SC]종료 중입니다. 시작
    18-04-24 20:00:15 0x1A48-00-1 eErrNoServiceLog(Service log!): setEndGame : 12
    happy happy joy joy. Your game is broken.
     
  2. Rakabn

    Joined:
    Apr 22, 2018
    Messages:
    26
    Likes Received:
    3
    Its alright dude, We all gotta get to work at some point :P.

    I have tried a full safe mode boot, and decided to try another one.
    The first time I ran one it CTD'ed after awhile, since it runs at like 20 frames.
    I tried it again and waited about 6 mins on the start button screen, so far no CTD, but I wonder if the frame rate is making it just take longer to CTD, but idk. About to try again in safe mode.

    Nvm Mait time is too strong.
     
  3. C0deM0nkey

    Joined:
    Feb 16, 2016
    Messages:
    233
    Likes Received:
    52
    Yeah, don't I know it. :D

    I actually wasn't referring to safe mode, which you get to by clicking Restart while holding the shift key, but instead something slightly different. But that's okay.

    In case you're interested, here it is on the MS support site:
    https://support.microsoft.com/en-us/help/929135/how-to-perform-a-clean-boot-in-windows

    I suggested clean boot because safe mode is much more extreme in what it aces out of the mix, and it's mainly meant for troubleshooting Windows BSODs and other bootup issues, like total driver failures; and it will perform like utter crap as you saw. However, it doesn't matter, safe mode also got you to the point of seeing that none of the services/drivers you're loading in a normal boot is causing a conflict with BDO. So that's good news in eliminating possibilities.

    Unfortunately, once things come back up, we'll be back at this problem since they aren't patching until tomorrow. However, when things do come back online, I was wondering if you could try something else and maybe it verifies what I'm seeing. Note, you'll want to be back on cumulative patch 371 (more on that in another post), so if you haven't already, head into your services and reenable Background Intelligent Transfer and Windows Update services (just set them to manual start). Go into settings, Windows update and check for updates. It should download and install the cumulative patch again. Let it do its thing and reboot.

    If you have a second monitor this works better, but if you don't, just config the game to run in either windowed mode or fullscreen windowed mode, so you can see other things on top of the game and see what's going on.

    You'll need a tool from Microsoft SysInternals:
    https://docs.microsoft.com/en-us/sysinternals/downloads/rammap

    You don't need to install it, just put it somewhere and you'll run it later.

    After having your machine running and idling for a good 30 mins after a normal reboot: Open task manager, go to the performance tab. Take a screenshot with the memory monitor selected. Use ALT+PRTSCRN to take a screenshot of just the active window, as I don't need the whole desktop snapped. Then click the link at the bottom labeled "Open Resource Monitor" and select the Memory tab on that window. Take a screenshot of that as well. If you don't have a second monitor, reorganize the windows so you can see them both. If you do, drag task manager and resource monitor over onto the other monitor. Then start the game, hop into your character and make sure task manager and resource monitor are still visible. Note whether the free value on the Resource Monitor is declining fairly rapidly and constantly, as the game is running. At about the 1.5 - 2 min mark where it's about to crash, take two more screenshots of both the task manager and resource monitor.

    After it crashes, run RAMMap: In the table in that application on the use counts tab, on the horizontal line is mapped files and in the vertical column is standby, note how much memory standby is reported as using. Please screenshot that as well. Is Windows using a large amount of memory for that? On mine as I was looking at it... Idling and running pretty much nothing but Chrome, it's using 18GB for instance, and that seems a bit high. It's not necessarily a problem if Windows is able to free some of that memory fast enough when another application needs it (and I think this is part of the problem btw). Next, in RAMMap, select the empty menu, then select empty standby list. Hit F5 to refresh the values in the app, you should see that the standby list memory has been reduced to almost nothing. Take another screenshot. You'll get some hard drive activity and if you hit F5 again, and you'll see that value climbing again as Windows refills the file cache Hopefully, it stabilizes somewhere well below what it was at before clearing the standby list (mine stopped at 4GB) with most of that previously allocated memory going back to the free value.

    Try to run the game again after clearing the standby list with RAMmap, and see if it doesn't stay running longer than before. Hopefully, significantly longer. When I have noticed things getting sluggish, I minimize the game, start RAMMap, use it to clear the standby memory and then can avoid the crash if I'm quick enough.

    Please post back with results and the screenshots you took, and lets see where things are at that point.
     
  4. Rakabn

    Joined:
    Apr 22, 2018
    Messages:
    26
    Likes Received:
    3

    Ill be trying this stuff in a bit. The GM's told me after todays patch it should have fixed my issue, which they have pointed out in my logs is that my cache is not loading.


    GM CreatorTuesday at 02:33
    Greetings Adventurer!

    According to your logs, Failed to open file!): 파일 읽기 실패 : C:\Users\Rakab\Documents\Black Desert\UserCache/1093355465467970833/sebLuaCacheData

    They had me delete my cache multiple times untill I had to literally send them pictures of me deleting the requested files. I do notice that deleting the cache requires permissions and am thinking its possible that it is having permission errors.

    Meh its something I figured id post before trying what you suggested here in a bit.
     
  5. C0deM0nkey

    Joined:
    Feb 16, 2016
    Messages:
    233
    Likes Received:
    52
    Yeah, definitely try that first and see if it helps things. I had suggested that in one of my earlier posts as well, along with wiping the bin and bin64 folders in the game installation, and then letting the launcher redownload the game binaries. It seemed to clear up a lot of the game client complains about not being to call LUA scripts in the logs and generally it seemed the game stability improved. If that doesn't help, then I'd also try removing the cache folder under the game installation folder as well. There's also one under C:\Users\<yourwindowsuserid>\AppData\Local\BlackDesertOnline that can be removed.

    The permissions issue might possibly occur if you're not running as an Administrator account, though it shouldn't really be an issue. However, I also forget how the permissions are laid out if you run a restricted account, since I always run my Windows accounts as Administrators. If you look in Settings > Account Info... Under the "Your Info" at the top, under your account name, does it say Administrator? If not, then you're on a normal user/limited rights account. More security, but more headaches too.

    If you are indeed running as Administrator on the machine, then there's the distinct possibility that your user profile has become corrupted, and the permissions issues would be evidence of that. I've had this happen a few times in the past unfortunately, especially in cases where a Bugcheck/BSOD (blue screen of death) occurred and the crash did damage to the profile. There are other possibilities, but it is a very common cause. In this case, you can test that possibility by creating a new Windows user account with Administrator permissions, log into it, then try running the game in the new account and see if it works fine in that freshly created user profile. If it works, you know there is an issue with the old account. There unfortunately is no way to really fix the old corrupted profile, so the answer then is to migrate/copy any files from the old profile to the new (which should fix the permissions problems on any files and folders). I'd recommend not grabbing folders and copying them, just make new folders and copy the files as you need to. Leave the old BlackDesert folder under your old Documents folder, don't copy it. Also, if you do migrate files, just be careful you don't copy any NTUSER.* files from the old user's profile (C:\users\<olduserid>) over and overwrite the ones in the new profile. Those old files will corrupt the new profile. It shouldn't be possible to make that mistake (i.e. the files should be locked and not overwriteable), but I also haven't tried it recently either. :)

    Also, I think you mentioned before this was a brand new Windows installation? It was a clean install directly of Win 10 right? Not an upgrade from an earlier version of Windows (vista/7/8/8.1)? I've seen profile permissions issues caused by upgrades from an older OS. Because the file system security model has changed slightly over time, the upgrade process doesn't always do things right.
     
  6. Ahrigato

    Joined:
    Sep 3, 2017
    Messages:
    17
    Likes Received:
    9
    Title say's it all. Game just closed while I was riding my horse through Kama. Not sure if this has been fixed yet but I'll try deleting the cache folder to see if that'd help.
     
    Brightcide likes this.
  7. Eques3n

    Eques3n Guardian 63 NA

    Joined:
    Nov 6, 2015
    Messages:
    309
    Likes Received:
    155
    Add me to the list.
     
    Brightcide likes this.
  8. Brightcide

    Joined:
    Jun 14, 2017
    Messages:
    878
    Likes Received:
    946
    I can't stay logged in for 5 minutes without crashing. Tried deleting Cache and Log folder contents in the game directory, tried deleting Dump and Cache folder from Documents > Black Desert Online, tried deleting AppData > Local > Temp folder contents, tried verifying game files... I'm running out of ideas.
     
  9. Brightcide

    Joined:
    Jun 14, 2017
    Messages:
    878
    Likes Received:
    946
    I can't stay logged in for 5 minutes without crashing after this latest patch/migration. Tried deleting Cache and Log folder contents in the game directory, tried deleting Dump and Cache folder from Documents > Black Desert Online, tried deleting AppData > Local > Temp folder contents, tried verifying game files... I'm running out of ideas.

    Running Windows 10 Home Edition
    Intel i7-6700k @4.5Ghz
    MSI Z170A
    Gigabyte AORUS 1080 Ti
    16GB of DDR4-2132
    PNY 240GB SSD
    Windows managed page file

    Playing on 1440p, High Textures, Low Preset.

    Temps are fine, CPU/GPU utilization is normal, nothing seems out of the ordinary.
     
  10. Synxin

    Joined:
    Nov 12, 2017
    Messages:
    2
    Likes Received:
    0
    I'm getting the exact same issue.
     
  11. Serimorph

    Joined:
    Mar 30, 2016
    Messages:
    51
    Likes Received:
    81
    Yup same issue after migration and patch for me as well
     
  12. Gungnir

    Joined:
    Apr 18, 2018
    Messages:
    6
    Likes Received:
    1
    I have tried heaps of different things now. Still crashing to desktop within ~2 minutes.
    Issued a support ticket sooooo good luck to me!
     
  13. Methuzela

    Joined:
    Sep 5, 2016
    Messages:
    7
    Likes Received:
    1
    Same issue, been doing it since Koi event started. Was really hoping today's patch would fix it but it just seems worse.
     
  14. Evaerys

    Joined:
    Mar 28, 2016
    Messages:
    3
    Likes Received:
    0
    Problem still persisting here as well.
     
  15. Tetchy

    Joined:
    Apr 27, 2018
    Messages:
    1
    Likes Received:
    0
    Problem worse now than it was prior to migration. I can't stay on longer than 10-15 minutes. All the normal "Turn it off and on/delete this or that" suggestions have failed to correct the issue.
     
  16. Methuzela

    Joined:
    Sep 5, 2016
    Messages:
    7
    Likes Received:
    1
    ipconfig /flushdns

    Not saying its fixed but I ran that and I have stayed on longer than I have all day.
     
  17. VivaLa

    Joined:
    Aug 30, 2017
    Messages:
    38
    Likes Received:
    14
    Same problem here. Game closes by itself in random moments. Cant leave pc for afk fishing, cant make crates...
     
  18. GM Kaioken

    Game Master

    Joined:
    Oct 19, 2017
    Messages:
    2,989
    Likes Received:
    332
    If you guys are still suffering from CTDs, could you please send us in a ticket with your Log Folder + DxDiag logs attached?
     
  19. Methuzela

    Joined:
    Sep 5, 2016
    Messages:
    7
    Likes Received:
    1
    Yesterday I wasn't able to stay on for more than 10-15 mins but after running ipconfig /flushdns I was on all night. Worth a try because it seems to have worked for me.
     
  20. ElectricLovelyland

    Joined:
    Apr 27, 2018
    Messages:
    11
    Likes Received:
    3
    Same issue here, sending in my DxDiag+Logs did nothing at all; just more talking in circles. This is absurd and really needs to be fixed.
    I paid for a game that should be working.
     

Share This Page